Thursday, June 19, 2014

Using WiDi on the Dell XPS 12 running Windows 8.1

There seems to be a bit of confusion on how to get WiDi up and running on some newer devices, especially if they don’t ship with the WiDi software pre-installed.  This was the case with my Dell XPS 12.

So really, all you need to do is go here but I’ll walk through some of the steps since things have changed since Windows 7 and the documentation hasn’t all been updated:

http://www.intel.com/p/en_US/support/highlights/wireless/wireless-display 

Go to the link above and run the WiDi update tool – it’s going to make sure you have all of the nessesary drivers up to date.  After a fresh Windows 8.1 installation the WiDi updater upgraded my WiFi drivers to version 17.x.

On Windows 8.1 you no longer need a stand-alone WiDi app, it’s integrated into Windows.

Step 1: Turn on your TV & WiDi receiver, and make sure you can see the WiDi connection screen on your TV.  I’m using the NetGear PTV3000.

Step 2: Open the charms bar (swipe in from the right) and click on “Settings” and then “Change PC Settings” at the bottom of the charm flyout.

Step 3: Select “Display” on the left and then scroll to the bottom and click on “Connect to a wireless display”.

Step 4: Click “Add a wireless display” on the flyout.

 WiDi1

Step 5: Allow Windows to search and then select your WiDi device from the list

WiDi2

WiDi3

 

Enjoy!

 widi4

 

My display lags slighlt when connected, but it works very well and the connection is stable.

If you’re having connection problems, make sure your WiDi receiver’s firmware is up to date.  I did need to update my Netgear PVT3000.